IT Notes‎ > ‎Java‎ > ‎IDE‎ > ‎

Eclipse 3.5 不能启动问题解决——修改参数配置文件

我的上网本上的 Eclipse 3.5 JEE 版本是用不了的. 启动的时候会如下图的报错.


光报错, 连日志都没有. 参照非春哥的解释, 修改了 {$eclipse_home}/eclipse.ini 文件, 修改后的如下:
-startup
plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
-product
org.eclipse.epp.package.jee.product
-vm
C:\Program Files\Java\jdk1.6.0_16\bin\javaw.exe
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
黄色高亮部分是新加进去的, 如果不新加, 直接修绿色高亮部分为 -Xmx256m, Eclipse 也能正常启动, 但使用可能不稳定了.

问题: eclipse.ini文件, 里边有些参数以双中连线开头, 需要改成单中连线吗?
问题怎么和自己结束? 上面的说法其实是不妥的,-- 和 - 的具体含义有待查证。TODO

注: 这个问题, 还出现办公室的机器上, 李莹的机器上也出现问题. 可能是 Eclipse 3.5 的 Windows 版本的一个普遍问题.

参考:
关于eclipse"JVM terminated. Exit code=-1"这个问题 (这篇文还谈到了如果Linux平台上出现这样的问题的解决方法, 它也提供了两个分析原因的链接)
Comments