IT Notes‎ > ‎Operation System‎ > ‎Linux‎ > ‎

在 Ubuntu 上用 QQ(已过期)

按:此文已过期,目前在 Ubuntu 上已经不能再使用腾讯官方的 Linux 版 QQ,只能用 Web 版或通过 Wine 方式使用 Windows 版。但此文中提到的在线制作 PNG 格式方法还是有用的,对问题过程的记录和分析对个人来讲也有一定回顾价值(2014.11)

一、安装使用QQ的步骤

  1. 下载通用版。地址:http://im.qq.com/qq/linux/download.shtml 的第三个,即 tar.gz 包。
  2. 解压。我解压后的目录是:/home/iridium/program/linuxqq_v1.0.2-beta1_i386
  3. 写脚本。脚本内容:
    #start qq
    cd ~/program/linuxqq_v1.0.2-beta1_i386
    ./qq
  4. 保存脚本文件为~/program/linuxqq_v1.0.2-beta1_i386/qq.sh
  5. 赋予脚本文件可执行属性:chmod +x qq.sh
  6. 对qq.sh在桌面创建启动器 或者 放到‘应用菜单’目录(‘系统’-‘首选项’-‘主菜单’里设置)

二、菜单设置过程

  1. 制作 LOGO:
  2. Google 一个 QQ 图标。
  3. png 转s vg 到网站 http://vectormagic.com/home 上完成。
  4. LOGO 文件放到:/usr/share/icons/hicolor/scalable/apps 里,注意是 svg 格式的。
  5. ‘系统’-‘首选项’-‘主菜单‘中添加一个启动项
(注意,图标显示可能有问题,没关系,注销一下应该就好了。)

三、报错

通过控制台启动,目前会报错:
iridium@iridium-laptop:~/program/linuxqq_v1.0.2-beta1_i386$ ./qq
Gtk-Message: Failed to load module "canberra-gtk-module": /usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so: wrong ELF class: ELFCLASS64

但不影响使用。

四、强制关闭 QQ

偶尔 QQ 会出现问题,导致桌面使用异常,并且不能通过鼠标关闭,这时只能通过控制台用命令行关闭。步骤如下:
  1. Ctrl + Alt + F3 进入控制台,输入用户名密码登录
  2. ps -ef | grep qq 查出 qq 的 PID,不妨假设为12345
  3. 杀死进程:kill -9 12345

五、我的故事

本机的 QQ 是用的是通用版。也就是 http://im.qq.com/qq/linux/download.shtml 上的第三个。

这个版本的QQ解压后,同一个文件夹下有两个文件,一个是可执行的 qq,一个是 res.db 的文件。我把它们放到了~/program/QQ 目录下,启动的 时候双击名为 QQ 的文件就行了。但每次都要打开 ~/program/QQ 目录,也比较麻烦,遂在桌面建一启动器,指向 ~/program/QQ/qq,但 启动的时候会报错——找不到 res.db。尝试把 qq 和 res.db 都软连接到桌面,点击桌面的 qq,就可以正常使用了。但还是比较不爽的是,明明只需要 点一个文件 qq 就应该运行的,偏偏在桌面上不得不放两个文件的连接。

为什么不尝试一下脚本?OK,一下就搞定了:首先 cd 到 qq 所在的目录,其次运行 qq,尝试了一下,果然可以,下面是脚本的文本,放这里备份一下:
#start qq
cd ~/program/QQ
./qq

注意脚本写好后,要 chmod 766 改变一下脚本的执行权限。

六、其他方式

以上皆为使用腾讯公司官版的 QQ,也可以在其他软件上登录使用 QQ,比如 Empathy,但协议需要选择 QQ2008,否则不能登录。这么做也有一个问题,那就是可能被腾讯发现用了非官方的客户端,帐户被腾讯锁住,下次登录要验证密码,很烦。
Comments